码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4352 数位dp

时间:2017-08-21 22:20:18      阅读:315      评论:0      收藏:0      [点我收藏+]

标签:mis   osi   区间   craft   example   little   chmod   find   mission   

XHXJ‘s LIS

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3081    Accepted Submission(s): 1291


Problem Description
#define xhxj (Xin Hang senior sister(学姐)) 
If you do not know xhxj, then carefully reading the entire description is very important.
As the strongest fighting force in UESTC, xhxj grew up in Jintang, a border town of Chengdu.
Like many god cattles, xhxj has a legendary life: 
2010.04, had not yet begun to learn the algorithm, xhxj won the second prize in the university contest. And in this fall, xhxj got one gold medal and one silver medal of regional contest. In the next year‘s summer, xhxj was invited to Beijing to attend the astar onsite. A few months later, xhxj got two gold medals and was also qualified for world‘s final. However, xhxj was defeated by zhymaoiing in the competition that determined who would go to the world‘s final(there is only one team for every university to send to the world‘s final) .Now, xhxj is much more stronger than ever,and she will go to the dreaming country to compete in TCO final.
As you see, xhxj always keeps a short hair(reasons unknown), so she looks like a boy( I will not tell you she is actually a lovely girl), wearing yellow T-shirt. When she is not talking, her round face feels very lovely, attracting others to touch her face gently。Unlike God Luo‘s, another UESTC god cattle who has cool and noble charm, xhxj is quite approachable, lively, clever. On the other hand,xhxj is very sensitive to the beautiful properties, "this problem has a very good properties",she always said that after ACing a very hard problem. She often helps in finding solutions, even though she is not good at the problems of that type.
Xhxj loves many games such as,Dota, ocg, mahjong, Starcraft 2, Diablo 3.etc,if you can beat her in any game above, you will get her admire and become a god cattle. She is very concerned with her younger schoolfellows, if she saw someone on a DOTA platform, she would say: "Why do not you go to improve your programming skill". When she receives sincere compliments from others, she would say modestly: "Please don’t flatter at me.(Please don‘t black)."As she will graduate after no more than one year, xhxj also wants to fall in love. However, the man in her dreams has not yet appeared, so she now prefers girls.
Another hobby of xhxj is yy(speculation) some magical problems to discover the special properties. For example, when she see a number, she would think whether the digits of a number are strictly increasing. If you consider the number as a string and can get a longest strictly increasing subsequence the length of which is equal to k, the power of this number is k.. It is very simple to determine a single number’s power, but is it also easy to solve this problem with the numbers within an interval? xhxj has a little tired,she want a god cattle to help her solve this problem,the problem is: Determine how many numbers have the power value k in [L,R] in O(1)time.
For the first one to solve this problem,xhxj will upgrade 20 favorability rate。
 

 

Input
First a integer T(T<=10000),then T lines follow, every line has three positive integer L,R,K.(
0<L<=R<263-1 and 1<=K<=10).
 

 

Output
For each query, print "Case #t: ans" in a line, in which t is the number of the test case starting from 1 and ans is the answer.
 
Sample Input
1 123 321 2
 
Sample Output
Case #1: 139
 
Author
peterae86@UESTC03
 
Source
 

 题意:

求[L,R]区间中有多少这样的数:把他看成字符串时他的LIS是k

代码:

//数位dp+LIS的那个nlogn方法。用sta(二进制压缩)记录LIS中涉及到了那些数。还要注意前导0的处理。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;
const int maxn=100000;
int bit[50],k;
ll dp[50][1<<10][12];
int yes(int sta)
{
    int cnt=0;
    while(sta){
        cnt+=sta&1;
        sta>>=1;
    }
    return cnt==k;
}
int make(int x,int sta)
{
    int i;
    for(i=0;i<=9;i++)
        if(sta&(1<<i)&&i>=x) break;
    if(i<=9){
        sta^=(1<<i);
        sta|=(1<<x);
    }else sta|=(1<<x);
    return sta;
}
ll dfs(int pos,int sta,bool limt,bool zero)
{
    if(pos==0) return yes(sta);
    if(!limt&&dp[pos][sta][k]!=-1)
        return dp[pos][sta][k];
    ll ans=0;
    int maxb=(limt?bit[pos]:9);
    for(int i=0;i<=maxb;i++){
        int ssta=make(i,sta);
        ans+=dfs(pos-1,(zero&&i==0)?0:ssta,limt&&(i==maxb),zero&&i==0);
    }
    if(!limt) 
        dp[pos][sta][k]=ans;
    return ans;
}
ll solve(ll n)
{
    int nu=0;
    while(n){
        bit[++nu]=n%10;
        n/=10;
    }
    return dfs(nu,0,1,1);
}
int main()
{
    int t;
    ll L,R;
    memset(dp,-1,sizeof(dp));
    scanf("%d",&t);
    for(int cas=1;cas<=t;cas++){
        scanf("%lld%lld%d",&L,&R,&k);
        printf("Case #%d: %lld\n",cas,solve(R)-solve(L-1));
    }
    return 0;
}

 

HDU 4352 数位dp

标签:mis   osi   区间   craft   example   little   chmod   find   mission   

原文地址:http://www.cnblogs.com/--ZHIYUAN/p/7406946.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!