码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1285 确定比赛名次

时间:2017-08-24 10:36:16      阅读:126      评论:0      收藏:0      [点我收藏+]

标签:input   rip   push   memset   algo   void   scan   cst   数据   

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28782    Accepted Submission(s): 11466


Problem Description
有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。
 

 

Input
输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。
 

 

Output
给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。
 

 

Sample Input
4 3
1 2
2 3
4 3
 

 

Sample Output
1 2 4 3
 

 

Author
SmallBeer(CML)
 

 

Source
 

拓扑排序裸题

#include <algorithm>
#include <cstring>
#include <cstdio>
#include <queue>
#define N 505
using namespace std;
priority_queue<int,vector<int>,greater<int> >q;
struct Edge{
    int next,to;
}edge[N*N];
int ans[N],r=0,head[N],cnt,rd[N],n,m;
void tppx()
{
    for(int i=1;i<=n;++i) if(!rd[i]) q.push(i) ;
    for(int now;!q.empty();)
    {
        now=q.top();q.pop();
        ans[++r]=now;
        for(int i=head[now];i;i=edge[i].next)
        {
            int v=edge[i].to;
            if(rd[v])
            {
                rd[v]--;
                if(!rd[v]) q.push(v) ; 
            }
        }
    }
}
inline void ins(int u,int v)
{
    edge[++cnt].next=head[u];
    edge[cnt].to=v;
    head[u]=cnt;
}
int main()
{
    for(;scanf("%d%d",&n,&m)!=EOF;)
    {
        memset(edge,0,sizeof(edge));
        memset(head,0,sizeof(head));
        memset(rd,0,sizeof(rd));
        r=cnt=0;
        for(int a,b;m--;)
        {
            scanf("%d%d",&a,&b);
            ins(a,b);
            rd[b]++;
        }
        tppx();
        for(int i=1;i<r;++i) printf("%d ",ans[i]);
        printf("%d\n",ans[r]);
    }
    return 0;
}

 

hdu 1285 确定比赛名次

标签:input   rip   push   memset   algo   void   scan   cst   数据   

原文地址:http://www.cnblogs.com/ruojisun/p/7421236.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!