码迷,mamicode.com
首页 > 其他好文 > 详细

HDU——1068 Girls and Boys

时间:2017-08-24 20:12:35      阅读:195      评论:0      收藏:0      [点我收藏+]

标签:printf   ast   can   sample   turn   and   i++   amp   getch   

          Girls and Boys

          Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
              Total Submission(s): 12246    Accepted Submission(s): 5768


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

 

Sample Input
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

 

Sample Output
5 2
 

 

Source
 
 
二分图的最大匹配数(裸题)
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#define N 1010
using namespace std;
bool vis[N];
int t,n,m,x,y,ans,girl[N],map[N][N];
int read()
{
    int x=0,f=1; char ch=getchar();
    while(ch<0||ch>9) {if(ch==-) f=-1; ch=getchar();}
    while(ch<=9&&ch>=0){x=x*10+ch-0;ch=getchar();}
    return x*f;
}
int find(int x)
{
    for(int i=1;i<=n;i++)
    {
        if(!vis[i]&&map[x][i])
        {
            vis[i]=true;
            if(girl[i]==-1||find(girl[i])) {girl[i]=x;return 1;}
        }
    }
    return 0;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        ans=0;
        memset(map,0,sizeof(map));
        memset(girl,-1,sizeof(girl));
        for(int i=1;i<=n;i++)
        {
            x=read();m=read();
            while(m--)
              y=read(),map[x+1][y+1]=1; 
        }
        for(int i=1;i<=n;i++)
        {
            memset(vis,0,sizeof(vis));
            ans+=find(i);
        }
        printf("%d\n",(2*n-ans)/2);
    }
    return 0;
}

 

HDU——1068 Girls and Boys

标签:printf   ast   can   sample   turn   and   i++   amp   getch   

原文地址:http://www.cnblogs.com/z360/p/7424451.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!