码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2176 取(m堆)石子游戏 博弈

时间:2017-08-24 22:37:29      阅读:130      评论:0      收藏:0      [点我收藏+]

标签:博弈   inf   整数   out   else   names   scan   cep   tle   

取(m堆)石子游戏

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3598    Accepted Submission(s): 2151


Problem Description
m堆石子,两人轮流取.只能在1堆中取.取完者胜.先取者负输出No.先取者胜输出Yes,然后输出怎样取子.例如5堆 5,7,8,9,10先取者胜,先取者第1次取时可以从有8个的那一堆取走7个剩下1个,也可以从有9个的中那一堆取走9个剩下0个,也可以从有10个的中那一堆取走7个剩下3个.
 

 

Input
输入有多组.每组第1行是m,m<=200000. 后面m个非零正整数.m=0退出.
 

 

Output
先取者负输出No.先取者胜输出Yes,然后输出先取者第1次取子的所有方法.如果从有a个石子的堆中取若干个后剩下b个后会胜就输出a b.参看Sample Output.
 

 

Sample Input
2 45 45 3 3 6 9 5 5 7 8 9 10 0
 

 

Sample Output
No Yes 9 5 Yes 8 1 9 0 10 3

 

Nim博弈并要求给出策略

新开两个数组记录完事

 

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <vector>
#include <iomanip>
#include <math.h>
#include <map>
using namespace std;
#define FIN     freopen("input.txt","r",stdin);
#define FOUT    freopen("output.txt","w",stdout);
#define INF     0x3f3f3f3f
#define INFLL   0x3f3f3f3f3f3f3f
#define lson    l,m,rt<<1
#define rson    m+1,r,rt<<1|1
typedef long long LL;
typedef pair<int, int> PII;
using namespace std;

int a[200005];
int p1[200005];
int p2[200005];

int main() {
    //FIN
    int n;
    while(~scanf("%d", &n) && n) {
        int ans = 0;
        int cnt = 0;
        for(int i = 1; i <= n; i++) {
            scanf("%d", &a[i]);
            ans ^= a[i];
        }
        for(int i = 1; i <= n; i++) {
            if((ans ^ a[i]) < a[i]) {
                p1[cnt] = i;
                p2[cnt] = a[i] - (ans ^ a[i]);
                cnt++;
            }
        }
        if(ans == 0) puts("No");
        else {
            puts("Yes");
            for(int i = 0; i < cnt; i++) {
                printf("%d %d\n", a[p1[i]], a[p1[i]] - p2[i]);
            }
        }

    }

    return 0;
}

  

HDU 2176 取(m堆)石子游戏 博弈

标签:博弈   inf   整数   out   else   names   scan   cep   tle   

原文地址:http://www.cnblogs.com/Hyouka/p/7425334.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!