码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3628 Bookshelf 2

时间:2017-08-26 11:27:37      阅读:137      评论:0      收藏:0      [点我收藏+]

标签:logs   思路   rip   color   ios   ota   ati   pst   std   

                                                                                                                                     Bookshelf 2
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10981   Accepted: 4860

Description

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal ‘excess‘ height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16
3
1
3
5
6

Sample Output

1

Source

思路:如果正向去计算大于d的最小值,贪心是很好实现的,但是DP想起来有点困难,所以就换了个思路。设sum为所有奶牛的高度和,则sum>=B,那么我们就可以设有一个容量为sum-B的背包,要让里面所有牛的高度尽量大,那余下的就是我们要求的值了,这就转换成简单的01背包了。
吐槽:不知道从哪位dalao博客里仿佛见到过“正难则反”(xxy是我o(*^▽^*)┛是我??ヽ(°▽°)ノ?),这个题目就让我想起了它。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,b,W,sum,num[25],f[2000000];
int main(){
    scanf("%d%d",&n,&b);
    for(int i=1;i<=n;i++){
        scanf("%d",&num[i]);
        sum+=num[i];
    }
    W=sum-b;
    for(int i=1;i<=n;i++)
        for(int j=W;j>=num[i];j--)
            f[j]=max(f[j],f[j-num[i]]+num[i]);
    printf("%d",sum-f[W]-b);
}

 

poj 3628 Bookshelf 2

标签:logs   思路   rip   color   ios   ota   ati   pst   std   

原文地址:http://www.cnblogs.com/cangT-Tlan/p/7434530.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!