码迷,mamicode.com
首页 > 其他好文 > 详细

Til the cows Come Home

时间:2017-08-26 16:01:29      阅读:221      评论:0      收藏:0      [点我收藏+]

标签:tween   table   rails 4   pos   integer   sample   rect   class   org   

Til the Cows Come Home
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 58225   Accepted: 19854

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John‘s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

Source

题目大意
求n到1的最短路
题解
spfa
代码
#include<iostream>
#include<queue>
#include<cstring>
#include<cstdio>
#define maxn 1002
using namespace std;
queue<int>q;
int head[maxn],dis[maxn],inq[maxn];
int sumedge,t,n,x,y,z;
 
struct Edge{
    int x,y,z,nxt;
    Edge(int x=0,int y=0,int z=0,int nxt=0):
        x(x),y(y),z(z),nxt(nxt){}
}edge[maxn<<2];

void add(int x,int y,int z){
    edge[++sumedge]=Edge(x,y,z,head[x]);
    head[x]=sumedge;
}

void spfa(){
    memset(dis,0x3f,sizeof(dis));
    dis[1]=0;inq[1]=1;q.push(1);
    while(!q.empty()){
        int now=q.front();q.pop();inq[now]=0;//经常忘了 
        for(int i=head[now];i;i=edge[i].nxt){
            int v=edge[i].y;
            if(dis[v]>dis[now]+edge[i].z){
                dis[v]=dis[now]+edge[i].z;
                if(!inq[v]){
                    inq[v]=1;q.push(v); 
                }
            }
        }
    } 
}

int main(){
    scanf("%d%d",&t,&n);
    for(int i=1;i<=t;i++){
        scanf("%d%d%d",&x,&y,&z);
        add(x,y,z);add(y,x,z);
    }
    spfa();
    printf("%d\n",dis[n]);
    return 0;
}

 

Til the cows Come Home

标签:tween   table   rails 4   pos   integer   sample   rect   class   org   

原文地址:http://www.cnblogs.com/zzyh/p/7435399.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!