码迷,mamicode.com
首页 > 其他好文 > 详细

Hdu 2119 Matrix

时间:2017-08-26 21:24:42      阅读:202      评论:0      收藏:0      [点我收藏+]

标签:this   string   bool   hdu   end   title   which   mini   false   

Matrix

Problem Description
Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the ‘1‘ in this row or this column .

Your task is to give out the minimum times of deleting all the ‘1‘ in the matrix.
 

 

Input
There are several test cases.

The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.
The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

n=0 indicate the end of input.
 

 

Output
For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the ‘1‘ in the matrix.
 

 

Sample Input
3 3 0 0 0 1 0 1 0 1 0 0
 

 

Sample Output
2
 

 

#include <cstdio>
#include <cstring>
using namespace std;
int n,m,s,t,ans,w[2333][2333],a[1000000];
bool vis[100000];

inline void read(int &now)
{
    char ch; ch=getchar(); now=0;
    while(ch>9||ch<0) ch=getchar();
    while(ch>=0&&ch<=9) now=now*10+ch-0,ch=getchar();
}

int find(int x)
{
    for(int i=1;i<=m;i++)
    {
        if(w[x][i]&&!vis[i])
        {
            vis[i]=true;
            if(!a[i]||find(a[i]))
            {
                a[i]=x;
                return 1;
            }
        }
    }
    return 0;
}

int main()
{
    while(scanf("%d",&n)&&n)
    {
        if(!n) break ;
        scanf("%d",&m);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                scanf("%d",&w[i][j]);
        for(int i=1;i<=n;i++)
        {
            memset(vis,false,sizeof(vis));
            if(find(i)) ans++;
        }
        printf("%d\n",ans);
        memset(w,0,sizeof(w));
        memset(a,0,sizeof(a));
        ans=0;
    }
    return 0;
}

 

Hdu 2119 Matrix

标签:this   string   bool   hdu   end   title   which   mini   false   

原文地址:http://www.cnblogs.com/chen74123/p/7436290.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!