码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3336 Count the string (基础KMP)

时间:2017-08-26 22:14:45      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:char   基础   test   which   ase   pac   bsp   desc   长度   

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

InputThe first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
OutputFor each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.Sample Input
1
4
abab
Sample Output
6

题意为: 求每个前缀在字符串中出现的次数之和
分析:Next数组在KMP中的定义是 前缀和后缀的最大公共长度.
设ans为所求值 ans至少为len ,遍历Next数组,每次Next长度不为0时 就说明和前缀有公共部分 ans++;

代码如下:
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;

const int N = 1000002;
int Next[N];
char S[N], T[N];
int slen, tlen;//注意每次一定要计算长度
const int MOD=1e4+7;
void getNext()
{
    int j, k;
    j = 0; k = -1; Next[0] = -1;
    while(j < tlen)
        if(k == -1 || T[j] == T[k])
            Next[++j] = ++k;
        else
            k = Next[k];

}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&tlen);
        scanf("%s",T);
        getNext();
        int ans=tlen%MOD;
        for(int i=2;i<=tlen;i++){
            if(Next[i]>0)
            ans=(ans+1)%MOD;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

HDU 3336 Count the string (基础KMP)

标签:char   基础   test   which   ase   pac   bsp   desc   长度   

原文地址:http://www.cnblogs.com/a249189046/p/7436377.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!