标签:hdu 水题
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1266
Problem Description
Welcome to 2006‘4 computer college programming contest!
Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one... Ha-Ha!
Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.
Input
Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow.
Output
For each test case, you should output its reverse number, one case per line.
Sample Input
Sample Output
代码如下:
#include <cstdio>
#include <cstring>
int main()
{
int t;
char s[117];
scanf("%d",&t);
while(t--)
{
scanf("%s",s);
int k = 0;
int len = strlen(s);
if(s[0] == '-')
printf("-");
int flag = 0;
for(int i = len-1; i >= 0; i--)
{
if(s[i]=='0'&&flag==0)
k++;
else if(s[i]=='-')
continue;
else
{
flag = 1;
printf("%c",s[i]);
}
}
for(int i = 0; i < k; i++)
printf("0");
printf("\n");
}
return 0;
}
HDU 1266 Reverse Number(字符串逆转 水题)
标签:hdu 水题
原文地址:http://blog.csdn.net/u012860063/article/details/39084235