码迷,mamicode.com
首页 > 其他好文 > 详细

hdu3555 Bomb (数位dp入门题)

时间:2017-08-27 12:48:37      阅读:144      评论:0      收藏:0      [点我收藏+]

标签:bom   time   java   lin   mit   代码   miss   erro   desc   

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 19698    Accepted Submission(s): 7311

Problem Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.
The input terminates by end of file marker.

Output

For each test case, output an integer indicating the final points of the power.

Sample Input

3 1 50 500

Sample Output

0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.

代码(dfs解法):

#include<iostream>
#include<cstring>
#define LL long long
using namespace std;

LL bit[25], dp[25][2];

LL dfs(int pos, int is4, int lim)
{
    if(pos<0) return 1;
    if(!lim && dp[pos][is4]!=-1) return dp[pos][is4];
    int las=lim?bit[pos]:9;
    LL res=0;
    for(int i=0; i<=las; ++i)
        if(!(is4 && i==9))
            res+=dfs(pos-1, i==4, lim&&i==las);
    if(!lim) dp[pos][is4]=res;
    return res;
}

int main()
{
    int T;
    memset(dp, -1, sizeof(dp));
    cin>>T;
    while(T--)
    {
        LL n;
        cin>>n;
        LL len=0, m=n;
        while(n)
        {
            bit[len++]=n%10;
            n/=10;
        }
        LL ans=m-dfs(len-1, 0, 1)+1;
        cout<<ans<<endl;
    }
    return 0;
}

 

hdu3555 Bomb (数位dp入门题)

标签:bom   time   java   lin   mit   代码   miss   erro   desc   

原文地址:http://www.cnblogs.com/xiepingfu/p/7439983.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!