码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 1026 Ignatius and the Princess I

时间:2017-08-29 15:08:15      阅读:226      评论:0      收藏:0      [点我收藏+]

标签:first   ted   ++   least   bsp   class   cat   using   kill   

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 34530    Accepted Submission(s): 15051


Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can‘t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

 

Sample Input
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

 

Sample Output
3 5 1
 

#include <cstdio>
#include <algorithm>
using namespace std;
int a[1000001];

int main()
{
    int n;
    while(~scanf("%d",&n)) //!!!不加会超时 
        {                  // ~  !=EOF
            for(int i=0;i<n;i++)  
                scanf("%d",&a[i]);
            sort(a+1,a+n+1);
            printf("%d\n",a[(n+1)/2]);  //巧妙之处 
        }
    return 0;
}

 

 

 

HDOJ 1026 Ignatius and the Princess I

标签:first   ted   ++   least   bsp   class   cat   using   kill   

原文地址:http://www.cnblogs.com/biggan/p/7448225.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!