码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1856 More is better

时间:2014-05-10 02:41:33      阅读:291      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   java   

Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang‘s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

 

Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
 

 

Sample Output
4
2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 
又是一道并查集的题目
bubuko.com,布布扣
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
struct node
{
    int num,root;
}tree[10000005];

int find(int x)
{
    return x==tree[x].root?x:tree[x].root=find(tree[x].root);
}

void init()
{
    for (int i=0;i<=10000001;i++)
    {
        tree[i].num=0;
        tree[i].root=i;
    }
}

int main()
{
    int n,x,y,maxn;
    while (scanf("%d",&n)!=EOF)
    {
        init();
        maxn=0;
        for (int i=0;i<n;i++)
        {
            scanf("%d%d",&x,&y);
            maxn=max(maxn,x);
            maxn=max(maxn,y);
            x=find(x);
            y=find(y);
            if (x!=y) tree[x].root=y;
        }
        int ans=0;
        for (int i=0;i<=maxn;i++)
        {
            tree[find(i)].num++;
            if (ans<tree[find(i)].num) ans=tree[find(i)].num;
        }
        printf("%d\n",ans);
    }
    return 0;
}
bubuko.com,布布扣

 

 

hdu 1856 More is better,布布扣,bubuko.com

hdu 1856 More is better

标签:des   style   blog   class   code   java   

原文地址:http://www.cnblogs.com/chensunrise/p/3719757.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!