码迷,mamicode.com
首页 > 其他好文 > 详细

Bone Collector-HDU

时间:2017-08-31 17:58:42      阅读:157      评论:0      收藏:0      [点我收藏+]

标签:数组   panel   nes   problem   mod   source   als   logs   auth   

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

技术分享
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
Sample Output
14
Author
Teddy
Source
思路:
 
 
一维代码:
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
long long max(long long num1,long long num2)//比较函数
{
return num1>num2?num1:num2;
}
long long dp[1005];//定义背包数组
int main()
{
int N;
int i,j,k;
int bone[1005];//定义价值
int volume[1005];//定义容量
int t;
scanf("%d",&t);
while(t--)
{
memset(dp,0,sizeof(dp));//初始化
int count,weight;
scanf("%d%d",&count,&weight);//输入组数和总重量
for(j=1;j<=count;j++)
scanf("%d",&bone[j]);
for(j=1;j<=count;j++)
scanf("%d",&volume[j]);
for(i=1;i<=count;i++)
{
    for(k=weight;k>=0;k--)
{
        if(k-volume[i]<0)//装不下
        {
            break;
        }
        else
            dp[k]=max(dp[k-volume[i]]+bone[i],dp[k]);
        cout << dp[k] << endl;
    }
}
printf("%lld\n",dp[weight]);
}
return 0;
}

 

Bone Collector-HDU

标签:数组   panel   nes   problem   mod   source   als   logs   auth   

原文地址:http://www.cnblogs.com/gcter/p/7459420.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!