码迷,mamicode.com
首页 > 其他好文 > 详细

CSUOJ 1336 Interesting Calculator 优先队列

时间:2014-09-06 12:31:03      阅读:338      评论:0      收藏:0      [点我收藏+]

标签:c++

Description

There is an interesting calculator. It has 3 rows of buttons.

 

Row 1: button 0, 1, 2, 3, ..., 9. Pressing each button appends that digit to the end of the display.

Row 2: button +0, +1, +2, +3, ..., +9. Pressing each button adds that digit to the display.

Row 3: button *0, *1, *2, *3, ..., *9. Pressing each button multiplies that digit to the display.

 

Note that it never displays leading zeros, so if the current display is 0, pressing 5 makes it 5 instead of 05. If the current display is 12, you can press button 3, +5, *2 to get 256. Similarly, to change the display from 0 to 1, you can press 1 or +1 (but not both!).

 

Each button has a positive cost, your task is to change the display from x to y with minimum cost. If there are multiple ways to do so, the number of presses should be minimized.

Input

There will be at most 30 test cases. The first line of each test case contains two integers x and y(0<=x<=y<=105). Each of the 3 lines contains 10 positive integers (not greater than 105), i.e. the costs of each button.

Output

For each test case, print the minimal cost and the number of presses.

Sample Input

12 256
1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1
12 256
100 100 100 1 100 100 100 100 100 100
100 100 100 100 100 1 100 100 100 100
100 100 10 100 100 100 100 100 100 100

Sample Output

Case 1: 2 2
Case 2: 12 3

题意:为了使 第一个数变成 第二个数  共有30种操作 在前一个数末尾加 0~9  前一个数加上 0~9  前一个数乘 0~9
每种操作都需要一定的费用 以表给出
求变成第二个的最小费用和它的操作次数

这道题考的是对优先队列的掌握。。。 
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
struct node {
  int x,num,sum;
  friend bool operator<(const node aa, node bb)
    {
        if(aa.sum!=bb.sum)
            return aa.sum>bb.sum;  //费用小优先
            else
                return aa.num>bb.num; //费用相同 次数少优先
    }
};
int vis[100005];  //标记这个数是否出现过
int q[4][20];
int a,b;
int ans,s;
void bfs()
{
    memset(vis,0,sizeof(vis));
    int i;
   priority_queue<node>qq;
   node now,next;
   now.num=0;
   now.sum=0;
   now.x=a;
   qq.push(now);
   while(!qq.empty())
   {
       now=qq.top();
       qq.pop();
       if(vis[now.x])   //  此题的关键
        continue;
       vis[now.x]=1;    //  此题的关键    利用优先队列  标记当前这个数 费用最小的状态  过滤那些 费用大于它的同一状态
       if(now.x==b)
       {
           ans=now.sum;
           s=now.num;
           return;
       }
       for(i=0;i<=9;i++)
       {
           next.x=now.x*10+i;
           next.sum=now.sum+q[1][i];
           if(next.x<=b&&!vis[next.x])
           {
                                        //标记状态的VIS[]数组不能出现在这里。。 否则就不是最小费用了。。
           next.num=now.num+1;
           qq.push(next);
            }
           next.x=now.x+i;
           next.sum=now.sum+q[2][i];
           if(next.x<=b&&!vis[next.x])
           {
           next.num=now.num+1;
           qq.push(next);
           }
           next.x=now.x*i;
        next.sum=now.sum+q[3][i];
           if(next.x<=b&&!vis[next.x])
           {

           next.num=now.num+1;
           qq.push(next);
            }
       }
   }
}
int main()
{
    int i,j;
    int t=0;
    while(~scanf("%d%d",&a,&b))
    {
        t++;
        for(i=1;i<=3;i++)
            for(j=0;j<=9;j++)
                scanf("%d",&q[i][j]);
        bfs();
        printf("Case %d: %d %d\n",t,ans,s);
    }

    return 0;
}



CSUOJ 1336 Interesting Calculator 优先队列

标签:c++

原文地址:http://blog.csdn.net/axuan_k/article/details/39099551

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!