码迷,mamicode.com
首页 > 其他好文 > 详细

B - Radar Installation poj 1328【贪心】

时间:2017-09-05 00:22:26      阅读:167      评论:0      收藏:0      [点我收藏+]

标签:题意   nss   node   blog   pac   pos   poi   ini   mina   

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
技术分享 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1
题意:给出坐标点的总数n和雷达辐射半径R,再给你n个坐标,问在X轴上最少需要多少个雷达可以覆盖所有坐标点。
思路:待更新。。。。

 

#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define N 1100
struct node {
    double x1,x2;
}c[N];

double cmp(struct node a,struct node b)
{
    if(a.x1 > b.x1 )
        return a.x1 < b.x1 ;
}
int main()
{
    int i,j,n,R,ans,t=0;
    double x,y,coords;
    while(scanf("%d%d",&n,&R),n!=0&&R!=0)//不能用(n+R)作为循环条件,因为3 -3这种情况不满足 
    {
        ans = 1;
        if(R <= 0)//先判断半径是否满足条件 
            ans = -1;

        for(i = 1; i <= n; i ++)
        {
            scanf("%lf%lf",&x,&y);//坐标是实数 
            if(fabs(y) > R)//纵坐标大于半径时  不满足条件 
            {
                ans = -1;
            }
            else
            {
                coords = sqrt(R*R-y*y);
                c[i].x1 = x - coords;//计算与x轴相交的左右端点 
                c[i].x2 = x + coords;
            }
        }
        if( ans == -1)
        {
            printf("Case %d: %d\n",++t,ans);
            continue;
        }
        sort(c+1,c+1+n,cmp);//结构体排序 
        coords = c[1].x2 ;//初始化为最左坐标的右端点 
        
        for(i = 2; i <= n; i ++)
        {
            if(c[i].x1 > coords)//如果下一个坐标的左端点大于上一个坐标右端点 说明两者没有公共区间 
            {
                ans ++;
                coords = c[i].x2 ;
            }
            else if(c[i].x2 < coords)//如果下一个坐标的右端点小于上一个坐标的右端点,说明存在公共区间 
                coords = c[i].x2 ;
        }
        printf("Case %d: %d\n",++t,ans);
    }
    return 0;
}

 

B - Radar Installation poj 1328【贪心】

标签:题意   nss   node   blog   pac   pos   poi   ini   mina   

原文地址:http://www.cnblogs.com/chengdongni/p/7476214.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!