码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 3507 Print Article

时间:2017-09-05 17:56:36      阅读:186      评论:0      收藏:0      [点我收藏+]

标签:cer   a long   误差   ges   otto   转化   for   col   print   

http://acm.hdu.edu.cn/showproblem.php?pid=3507

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)

Problem Description
Zero has an old printer that doesn‘t work well sometimes. As it is antique, he still like to use it to print articles. But it is too old to work for a long time and it will certainly wear and tear, so Zero use a cost to evaluate this degree.
One day Zero want to print an article which has N words, and each word i has a cost Ci to be printed. Also, Zero know that print k words in one line will cost
技术分享

M is a const number.
Now Zero want to know the minimum cost in order to arrange the article perfectly.
 
Input
There are many test cases. For each test case, There are two numbers N and M in the first line (0 ≤ n ≤ 500000, 0 ≤ M ≤ 1000). Then, there are N numbers in the next 2 to N + 1 lines. Input are terminated by EOF.
 
Output
A single number, meaning the mininum cost to print the article.
 

 

Sample Input
5
5
5
9
5
7
5
 
Sample Output
230
 
斜率优化
把斜率转化为乘积的形式,避免浮点数误差
#include<cstdio>
#include<cstring>
#define N 500001
using namespace std;
typedef long long LL;
LL sum[N],dp[N];
int c,q[N],head,tail; 
long long up(int k,int j) 
{
    return dp[j]-dp[k]-sum[k]*sum[k]+sum[j]*sum[j];
}
long long down(int k,int j)
{
    return 2*(sum[j]-sum[k]);
}
int main()
{
    int n,m,x;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(sum,0,sizeof(sum));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&x);
            sum[i]=sum[i-1]+x;
        }
        head=tail=0;
        memset(q,0,sizeof(q));
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            while(head<tail && up(q[head],q[head+1])<=sum[i]*down(q[head],q[head+1])) head++;
            dp[i]=dp[q[head]]+m+(sum[i]-sum[q[head]])*(sum[i]-sum[q[head]]);
            while(head<tail && up(q[tail-1],q[tail])*down(q[tail],i)>=up(q[tail],i)*down(q[tail-1],q[tail])) tail--;
            q[++tail]=i;
        }
        printf("%lld\n",dp[n]);
    }
}

 

hdu 3507 Print Article

标签:cer   a long   误差   ges   otto   转化   for   col   print   

原文地址:http://www.cnblogs.com/TheRoadToTheGold/p/7479606.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!