码迷,mamicode.com
首页 > 其他好文 > 详细

The Himalayas(ZOJ)

时间:2014-09-07 18:36:25      阅读:228      评论:0      收藏:0      [点我收藏+]

标签:io   ar   for   2014   art   sp   on   c   amp   

/*The 2014 ACM-ICPC Asia Mudanjiang Regional First Round - A
The Himalayas

--------------------------------------------------------------------------------

Time Limit: 2 Seconds      Memory Limit: 65536 KB

--------------------------------------------------------------------------------

As an artist, Bob usually need to travel around the world. He made a lot of sketch of scenery on his journey. A famous spot he have visited recently is the Himalayas. The Himalayas is a mountain range in South Asia separating the plains of the Indian subcontinent from the Qinghai-Tibet Plateau. The Himalayas include over a hundred mountains exceeding 7,200 meters in elevation.

One day, Bob came up with an strange idea. He wanted to know the number of mountain peaks in his paintings. As his best friend, he turned to you for help. You are given a list of N height sampling values Hi. You should determine how many peaks are there. For all i which satisfies 2 <= i <= N - 1, Hi is defined as a peak if and only if Hi-1 < Hi > Hi+1.

Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains one integer N (1 <= N <= 50). The next line contains N integers Hi (1 <= Hi <= 8844). It is guaranteed that any two adjacent height sampling values will be different.

Output
For each test case, output the number of peaks.

Sample Input
2
9
1 3 2 4 6 3 2 3 1
5
1 2 3 4 5
Sample Output
3
0

*/
#include<stdio.h>
int main()
{
    int str[9000];
    int test,n,i;
    scanf("%d",&test);
    while(test--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        scanf("%d",&str[i]);
        int sum=0;
        for(i=1;i<n-1;)
        {
            if(str[i-1]<str[i]&&str[i]>str[i+1])
            {
                sum+=1;
                i+=2;
            }
            else
            {
                i++;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
   

The Himalayas(ZOJ)

标签:io   ar   for   2014   art   sp   on   c   amp   

原文地址:http://blog.csdn.net/hdd871532887/article/details/39121011

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!