码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1711 Number Sequence【kmp】

时间:2017-09-09 19:38:15      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:open   range   int   one   splay   cli   each   bin   bsp   

 
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 

InputThe first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 
OutputFor each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 
Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

技术分享
#include<stdio.h>
int a[1000010],b[10010];
int next[10010];
int n,m;
void getNext()
{
    int j,k;
    j=0;
    k=-1;
    next[0]=-1;
    while(j<m)
    {
        if(k==-1||b[j]==b[k])
          next[++j]=++k;
        else k=next[k];
    }    
}  
//返回首次出现的位置 
int KMP_Index()
{
    int i=0,j=0;
    getNext();
    
    while(i<n && j<m)
    {
        if(j==-1||a[i]==b[j])
        {
            i++;
            j++;
        }    
        else j=next[j];
        
    }    
    if(j==m) return i-m+1;
    else return -1;
}      
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
          scanf("%d",&a[i]);
        for(int i=0;i<m;i++)
          scanf("%d",&b[i]);
        printf("%d\n",KMP_Index());
    }    
    return 0;
}    
kuangbin模板

http://www.cnblogs.com/kuangbin/archive/2012/08/14/2638803.html

HDU 1711 Number Sequence【kmp】

标签:open   range   int   one   splay   cli   each   bin   bsp   

原文地址:http://www.cnblogs.com/Roni-i/p/7499027.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!