码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 3342 Legal or Not

时间:2017-09-10 22:51:46      阅读:270      评论:0      收藏:0      [点我收藏+]

标签:mod   simple   case   imp   hone   pop   ane   nio   exce   

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9164    Accepted Submission(s): 4252

Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it‘s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian‘s master and, at the same time, 3xian is HH‘s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B‘s master ans B is C‘s master, then A is C‘s master.
 
Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y‘s master and y is x‘s prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 
Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 
Sample Input
3 2 0 1 1 2 2 2 0 1 1 0 0 0
 
Sample Output
YES NO
 
Author
QiuQiu@NJFU
 
Source
 
Recommend
lcy   |   We have carefully selected several similar problems for you:  2647 3333 3339 3341 3336 
思路:经典的拓扑排序判环。
#include<queue>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define MAXN 100001
using namespace std;
int n,m,tot,num,vis[110],into[110];
int to[MAXN],net[MAXN],head[MAXN];
void add(int u,int v){
    to[++tot]=v;net[tot]=head[u];head[u]=tot;
}
int main(){
    while(scanf("%d%d",&n,&m)&&n!=0&&m!=0){
        tot=0;num=0;
        memset(to,0,sizeof(to));
        memset(net,0,sizeof(net));
        memset(into,0,sizeof(into));
        memset(head,-1,sizeof(head));
        for(int i=1;i<=m;i++){
            int x,y;
            scanf("%d%d",&x,&y);
            add(x,y);
            into[y]++;    
        }
        queue<int>que;
        for(int i=0;i<n;i++)
            if(!into[i]){
                num++;
                que.push(i);
            }
        while(!que.empty()){
            int now=que.front();
            que.pop();
            for(int i=head[now];i!=-1;i=net[i]){
                into[to[i]]--;
                if(!into[to[i]]){
                    num++;
                    que.push(to[i]);
                }
            }
        }
        if(num==n)    printf("YES\n");
        else printf("NO\n");
    }
}

 

 

hdu 3342 Legal or Not

标签:mod   simple   case   imp   hone   pop   ane   nio   exce   

原文地址:http://www.cnblogs.com/cangT-Tlan/p/7502587.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!