码迷,mamicode.com
首页 > 其他好文 > 详细

BFS PKU 1915

时间:2014-09-09 12:39:48      阅读:175      评论:0      收藏:0      [点我收藏+]

标签:bfs   简单题   

渣渣的我做算法只能做水题啊。bubuko.com,布布扣

又是一道BFS水题bubuko.com,布布扣

代码虐我千百遍,我待代码如初恋。我对代码是真爱啊bubuko.com,布布扣

Knight Moves
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 22041   Accepted: 10294

Description

Background 
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him? 
The Problem 
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov. 
For people not familiar with chess, the possible knight moves are shown in Figure 1. 
bubuko.com,布布扣

Input

The input begins with the number n of scenarios on a single line by itself. 
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <math.h>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
#include <iostream>
#include <deque>
using namespace std;
#define MAXN 300 + 5

struct node{
    int x;
    int y;
    int step;
};
int vis[MAXN][MAXN];
int n;
int fx,fy;
int xx[8] = {1,2,2,1,-1,-2,-2,-1};
int yy[8] = {2,1,-1,-2,-2,-1,1,2};

void BFS(int a,int b){
    queue<node>q;
    int i,j;
    int dx,dy;
    node front,rear;
    front.x = a;
    front.y = b;
    front.step = 0;
    vis[a][b] = 1;
    q.push(front);
    while(!q.empty()){
        front = q.front();
        q.pop();
        if(front.x==fx && front.y==fy){
            printf("%d\n",front.step);
        }
        for(i=0;i<8;i++){
            dx = front.x + xx[i];
            dy = front.y + yy[i];
            if(dx>=0&&dx<n&&dy>=0&&dy<n){
                if(vis[dx][dy] == 0){
                    rear.x = dx;
                    rear.y = dy;
                    rear.step = front.step+1;
                    vis[dx][dy] = 1;
                    q.push(rear);
                }
            }
        }
    }
}

int main(){
    int x1,y1;
    //int y1,y2;
    int T;

    while(~scanf("%d",&T)){
        while(T--){
            memset(vis,0,sizeof(vis));
            scanf("%d",&n);
            scanf("%d%d",&x1,&y1);
            scanf("%d%d",&fx,&fy);
            BFS(x1,y1);
        }
    }

    return 0;
}

 

BFS PKU 1915

标签:bfs   简单题   

原文地址:http://blog.csdn.net/zcr_7/article/details/39153371

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!