码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1532(最大流裸题)

时间:2014-09-09 13:05:28      阅读:252      评论:0      收藏:0      [点我收藏+]

标签:网络流   最大流   图论   

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9557    Accepted Submission(s): 4534


Problem Description
Every time it rains on Farmer John‘s fields, a pond forms over Bessie‘s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie‘s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 
 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond. 
 

Sample Input
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
 

Sample Output
50
 

Source
 

Recommend
lwg   |   We have carefully selected several similar problems for you:  1533 3338 1569 3572 3416 

#include<iostream>
#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
#include<map>
using namespace std;
const int maxn=200+5;
#define INF 1e8
int n,m;
int flow[maxn][maxn],a[maxn],p[maxn],cap[maxn][maxn];
int max_flow(int s,int t)
{
    memset(flow,0,sizeof flow);
    int f=0;
    for(;;)
    {
        memset(a,0,sizeof(a));
        a[s]=INF;
        queue<int>q;
        q.push(s);
        while(!q.empty())
        {
            int u=q.front();q.pop();
            for(int v=1;v<=n;v++)if(!a[v]&&cap[u][v]>flow[u][v])
            {
                p[v]=u;q.push(v);
                a[v]=min(cap[u][v]-flow[u][v],a[u]);
            }
        }
        if(!a[t])break;
        for(int u=t;u!=s;u=p[u])
        {
            flow[p[u]][u]+=a[t];
            flow[u][p[u]]-=a[t];
        }
        f+=a[t];
    }
    return f;
}
int main()
{
    ios_base::sync_with_stdio(false);
    while(cin>>n>>m)
    {
        memset(cap,0,sizeof cap);

        int u,v,w;
        for(int i=1;i<=n;i++)
        {
            cin>>u>>v>>w;
            cap[u][v]+=w;
        }
        cout<<max_flow(1,m)<<endl;
    }
    return 0;
}




hdu 1532(最大流裸题)

标签:网络流   最大流   图论   

原文地址:http://blog.csdn.net/acvcla/article/details/39138511

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!