码迷,mamicode.com
首页 > 其他好文 > 详细

DFS PKU 1979

时间:2014-09-09 16:07:49      阅读:256      评论:0      收藏:0      [点我收藏+]

标签:dfs

水题保平安bubuko.com,布布扣

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 22640   Accepted: 12223

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

‘.‘ - a black tile 
‘#‘ - a red tile 
‘@‘ - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <ctype.h>
#include <limits.h>
#include <string.h>
#include <string>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <queue>
#include <stack>
#include <deque>
#include <vector>
#include <set>
//#include <map>
using namespace std;
#define MAXN 20 + 5

char map[MAXN][MAXN];
int w,h;
int vis[MAXN][MAXN];
int num;

void DFS(int x,int y){
    if(x-1>=0&&x-1<h&&y>=0&&y<w&&vis[x-1][y]==0){
        if(map[x-1][y] == '.'){
            num++;
            vis[x-1][y] = 1;
            DFS(x-1,y);
        }
    }
    if(x>=0&&x<h&&y+1>=0&&y+1<w&&vis[x][y+1]==0){
        if(map[x][y+1] == '.'){
            num++;
            vis[x][y+1] = 1;
            DFS(x,y+1);
        }
    }
    if(x+1>=0&&x+1<h&&y>=0&&y<w&&vis[x+1][y]==0){
        if(map[x+1][y] == '.'){
            num++;
            vis[x+1][y] = 1;
            DFS(x+1,y);
        }
    }
    if(x>=0&&x<h&&y-1>=0&&y-1<w&&vis[x][y-1]==0){
        if(map[x][y-1] == '.'){
            num++;
            vis[x][y-1] = 1;
            DFS(x,y-1);
        }
    }
}

int main(){
    int i,j;

    while(~scanf("%d%d",&w,&h)){
        if(w==0 && h==0){
            break;
        }
        for(i=0;i<h;i++){
            scanf("%s",map[i]);
        }
        memset(vis,0,sizeof(vis));
        int flag = 0;
        for(i=0;i<h;i++){
            for(j=0;j<w;j++){
                if(map[i][j] == '@'){
                    vis[i][j] = 1;
                    num = 0;
                    DFS(i,j);
                    flag = 1;
                    break;
                }
            }
            if(flag == 1){
                break;
            }
        }
        printf("%d\n",num+1);
    }

    return 0;
}


 

DFS PKU 1979

标签:dfs

原文地址:http://blog.csdn.net/zcr_7/article/details/39156515

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!