标签:contains output this second algo blog span related nts
2017-09-22 22:01:19
writer:pprp
InputThe first line contains a number t(1≤t≤100)t(1≤t≤100), the number of the testcases. And there are no more than 22 testcases with n>1000n>1000.
For each testcase, the first line contains two numbers n,K(1≤n≤105,0≤K<109)n,K(1≤n≤105,0≤K<109).
The second line contains nn numbers ai(1≤ai≤109)ai(1≤ai≤109).
OutputFor each testcase, print a single line with a single number -- the answer.Sample Input
2
5 3
1 5 9 6 3
5 2
1 5 9 6 3
Sample Output
5
1
代码如下:
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 110000;
int arr[maxn];
int main()
{
int cas;
cin >> cas;
while(cas--)
{
int n, k;
cin >> n >> k;
int ans = 1;
for(int i = 0 ; i < n ; i++)
{
cin >> arr[i];
}
sort(arr,arr+n);
for(int i = n-1; i > 0 ; i--)
{
if(arr[i]-arr[i-1] > k)
break;
ans++;
}
cout << ans << endl;
}
return 0;
}
标签:contains output this second algo blog span related nts
原文地址:http://www.cnblogs.com/pprp/p/7577377.html