码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1576 A/B(&&2503 a/b+c/d)

时间:2017-09-23 17:14:39      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:技术   content   bottom   panel   技术分享   open   sed   mis   src   

A/B

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6677    Accepted Submission(s): 5295


Problem Description
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
 

 

Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
 

 

Output
对应每组数据输出(A/B)%9973。
 

 

Sample Input
2 1000 53 87 123456789
 

 

Sample Output
7922 6060

 

技术分享
#include<cstdio>
#include<cstring>
#define ll long long
const int mod=9973;
ll inv(ll a,ll b)
{
    ll ans=1;
    while(b)
    {
        if(b&1) ans=ans*a%mod;
        b>>=1;
        a=a*a%mod;
    }
    return ans;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        ll n,b;
        scanf("%lld %lld",&n,&b);
    //    printf("%d",mod);
        printf("%lld\n",(n*inv(b,mod-2))%mod);
    }
    return 0;
}
View Code

求逆元;

求(n*inv(b,mod-2))%mod;

注意用long long ;(我老是忘记!!)

下面是一道水题:gcd&&lcm

Problem Description
给你2个分数,求他们的和,并要求和为最简形式。
 

 

Input
输入首先包含一个正整数T(T<=1000),表示有T组测试数据,然后是T行数据,每行包含四个正整数a,b,c,d(0<a,b,c,d<1000),表示两个分数a/b 和 c/d。
 

 

Output
对于每组测试数据,输出两个整数e和f,表示a/b + c/d的最简化结果是e/f,每组输出占一行。
 

 

Sample Input
2 1 2 1 3 4 3 2 3
 

 

Sample Output
5 6 2 1

 

技术分享
#include<cstdio>
#include<cstring>
int gcd(int a,int b)
{
    if(!b) return a;
    return gcd(b,a%b);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int a,b,c,d;
        scanf("%d %d %d %d",&a,&b,&c,&d);
        //printf("%d\n",xx);
        int tlcm=b*d/gcd(b,d);
        int tup=a*(tlcm/b)+c*(tlcm/d);
        int tt=gcd(tlcm,tup);
        printf("%d %d\n",tup/tt,tlcm/tt);
    }
    return 0;
}
View Code

无聊写写;

 

hdu 1576 A/B(&&2503 a/b+c/d)

标签:技术   content   bottom   panel   技术分享   open   sed   mis   src   

原文地址:http://www.cnblogs.com/12fs/p/7581418.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!