码迷,mamicode.com
首页 > 其他好文 > 详细

PAT甲级 1001. A+B Format (20)

时间:2017-09-26 00:57:16      阅读:161      评论:0      收藏:0      [点我收藏+]

标签:less   test   enter   case   written   ted   end   div   c代码   

1001. A+B Format (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

 

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991

题意:把数字格式化,每三个数字中间要加上逗号。
思路:水题,数字小于等于三个就不需要加逗号了。
AC代码:
#include<iostream>
#include<algorithm>
#include<set>
#include<queue>
#include<cmath>
#include<vector>
#include<bitset>
#include<string>
using namespace std;
const int N_MAX = 1000000;
string transform(int a) {
  string s ="";
  if (a == 0) { s += 0; return s; }
  int k = 0;
  while (a) {
    s+= 0+(a % 10);
    a /= 10;
  }
    return s;
}

string judge(string s,bool flag) {

  if (s.size() <= 3) { 
    if (!flag) {
      reverse(s.begin(), s.end());
      return s;
    }
  else {
    s += -;
    reverse(s.begin(), s.end());
    return s;
     }
  }
  string cur;
  int size = s.size(),k=0;
  
  while (size > 3) {
    cur += s.substr(k,3);
    cur += ,;
    k += 3;
    size -= 3;
  }
  if (size <= 3 && size > 0)cur += s.substr(k, s.size());
  if (flag)cur += -;
  reverse(cur.begin(), cur.end());
  return cur;
}


int main() {
  int a, b;
  bool flag;
  while (cin>>a>>b) {
    flag = 0;//判断正负
    int c = a + b;
    if (c < 0)flag = 1;
    c = abs(c);
    string s= transform(c);
    s = judge(s,flag);
    cout << s << endl;
  }
  return 0;
}

 

PAT甲级 1001. A+B Format (20)

标签:less   test   enter   case   written   ted   end   div   c代码   

原文地址:http://www.cnblogs.com/ZefengYao/p/7594641.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!