码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3041 Asteroids(二分匹配模板题)

时间:2014-09-10 10:56:00      阅读:154      评论:0      收藏:0      [点我收藏+]

标签:poj   二分匹配   

题目链接:http://poj.org/problem?id=3041


Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source



题意:

一个n * n的矩阵,在矩阵上有 m 个小行星,每一个武器都可以消灭一行或一列的小行星
问最少使用的武器消灭所有的行星?


代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
#define MAXN 517
int N;
int g[MAXN][MAXN], linker[MAXN];
bool used[MAXN];
int dfs(int L)//从左边开始找增广路径
{
    int R;
    for(R = 1 ; R <= N ; R++ )//这个顶点编号从0开始,若要从1开始需要修改
    {
        if(g[L][R]!=0 && !used[R])
        {
            //找增广路,反向
            used[R]=true;
            if(linker[R] == -1 || dfs(linker[R]))
            {
                linker[R]=L;
                return 1;
            }
        }
    }
    return 0;//这个不要忘了,经常忘记这句
}
int hungary()
{
    int res = 0 ;
    int L;
    memset(linker,-1,sizeof(linker));
    for( L = 1 ; L <= N ; L++ )
    {
        memset(used,0,sizeof(used));
        if(dfs(L) != 0)
            res++;
    }
    return res;
}
int main()
{
    int k, res, L, R;
    while(~scanf("%d%d",&N,&k))
    {
        memset(g,0,sizeof(g));
        for(int i = 1 ; i <= k ; i++ )
        {
            scanf("%d%d",&L,&R);
            g[L][R] = 1;
        }
        res = hungary();
        printf("%d\n",res);
    }
    return 0 ;
}


POJ 3041 Asteroids(二分匹配模板题)

标签:poj   二分匹配   

原文地址:http://blog.csdn.net/u012860063/article/details/39177639

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!