码迷,mamicode.com
首页 > 其他好文 > 详细

POJ-2318 TOYS[计算几何]

时间:2017-10-02 11:49:14      阅读:171      评论:0      收藏:0      [点我收藏+]

标签:round   log   eterm   ges   block   thrown   计算   board   contain   

TOYS

Time Limit: 2000MS

Description

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.
John‘s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.
技术分享
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

题意:

一个矩形被n条线段分成了n+1个区域,然后询问每个区域里有几个玩具。

直接对玩具最左端的线段进行二分。

#include "stdio.h"
#include "iostream"
#include "algorithm"
#include "math.h"
#include "string.h"
using namespace std;
const int maxn = 1e5 + 10;
struct Point {
    int x, y;
    Point(int x = 0, int y = 0):x(x), y(y) {}
    void in(void) { scanf("%d%d", &x, &y);}  
};
struct Line {  
    Point a, b;
    int ang; 
    Line() {} 
    Line(const Line& L): a(L.a), b(L.b), ang(L.ang) {}  
    Line(const Point& a,const Point& b):a(a),b(b){
        if (a.x == b.x) ang = 0;
        else if ((a.y - b.y)/(a.x - b.y) < 0) ang = -1;
        else ang = 1;
    }  
    bool operator < (const Line& L) const {  
        return a.x<L.a.x;  
    }   
};  
Line line[maxn];
int res[maxn];
int n, m;
bool JudgePoint(Line L1, Point c, int mid) {
    int flag = (L1.a.x - L1.b.x)*(L1.a.y - L1.b.y); 
    if (flag == 0) return L1.a.x <= c.x;
    if (L1.a.x - L1.b.x > 0){    
        if (c.y*(L1.a.x - L1.b.x) > (L1.a.y - L1.b.y)*(c.x - L1.b.x)+L1.b.y*(L1.a.x - L1.b.x)) return flag < 0;
        else return flag > 0;
    }
    else {
        if (c.y*(L1.a.x - L1.b.x) < (L1.a.y - L1.b.y)*(c.x - L1.b.x)+L1.b.y*(L1.a.x - L1.b.x)) return flag < 0;
        else return flag > 0;
    }
}
void solve(Point c) {
    int ub = n + 1, lb = 0;
    int t;
    while (ub >= lb) {
        int mid = (ub + lb) >> 1;
        if (JudgePoint(line[mid], c, mid)) {
            t = mid; lb = mid + 1;
        }
        else ub = mid - 1;
    }
    res[t]++;
} 
int main(int argc, char const *argv[])
{
    int x1, y1, x0, y0, xu, xd; 
    while (scanf("%d", &n), n) {
        scanf("%d", &m);        
        memset(res, 0, sizeof(res));
        scanf("%d%d%d%d", &x0, &y1, &x1, &y0);
        line[0] = Line(Point(x0, y0), Point(x0, y1));
        line[n + 1] = Line(Point(x1, y0), Point(x1, y1));
        for (int i = 1; i <= n; i++) {
            scanf("%d%d", &xu, &xd);
            line[i] = Line(Point(xd, y0), Point(xu, y1));
        }

        sort(line, line+(n+1));
        Point p;
        for (int i = 0; i < m; i++) {
            p.in(); solve(p);
        }
        for (int i = 0; i <= n; i++) {
            printf("%d: %d\n", i, res[i]);
        }
        printf("\n");
    }
    return 0;
}

POJ-2318 TOYS[计算几何]

标签:round   log   eterm   ges   block   thrown   计算   board   contain   

原文地址:http://www.cnblogs.com/cniwoq/p/7619856.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!