码迷,mamicode.com
首页 > 其他好文 > 详细

PAT1008:Elevator

时间:2017-10-02 23:52:55      阅读:376      评论:0      收藏:0      [点我收藏+]

标签:blog   ret   lin   sam   content   standard   span   长度   文本   

1008. Elevator (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:
3 2 3 1
Sample Output:
41

思路
很简单的一道题,判断好楼层的移动方向,计算楼层差值即可。
代码
#include<iostream>
using namespace std;
int main()
{
  int N;
  while(cin >> N)
  {
    int cur = 0,next = 0,sum = 0;
    while(N--)
    {
      cin >> next;
      if(next - cur >= 0)
      {
        sum += (next - cur) * 6 + 5;
      }
      else
        sum += (cur - next) * 4 + 5;
      cur = next;
    }
    cout << sum << endl;
  }
}

 

PAT1008:Elevator

标签:blog   ret   lin   sam   content   standard   span   长度   文本   

原文地址:http://www.cnblogs.com/0kk470/p/7622937.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!