码迷,mamicode.com
首页 > 其他好文 > 详细

PAT1027:Colors In Mars

时间:2017-10-03 00:26:30      阅读:157      评论:0      收藏:0      [点我收藏+]

标签:cte   lin   min   lis   put   last   pac   line   tween   

1027. Colors in Mars (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

 

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input
15 43 71
Sample Output
#123456

思路
很简单的10进制数转换为13进制数问题
代码
#include<iostream>
using namespace std;
char a[14] = "0123456789ABC";
int main()
{
  int colors[3];
  while(cin >> colors[0] >> colors[1] >> colors[2])
  {
    cout <<"#";
    for(int i = 0;i < 3;i++)
    {
        cout << a[colors[i]/13] << a[colors[i] % 13];
    }
    cout << endl;
  }
}

 

 

PAT1027:Colors In Mars

标签:cte   lin   min   lis   put   last   pac   line   tween   

原文地址:http://www.cnblogs.com/0kk470/p/Pat.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!