码迷,mamicode.com
首页 > 其他好文 > 详细

PAT1063:Set Similarity

时间:2017-10-05 16:09:22      阅读:211      评论:0      收藏:0      [点我收藏+]

标签:tle   print   class   test   one   name   algorithm   i++   log   

1063. Set Similarity (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
Sample Output:
50.0%
33.3%

思路

求交集大小/并集大小的百分比,保留一位小数。

暂时直接用stl的set做,然而最后一个测试用例超时。。。
代码
待优化
#include<iostream>
#include<algorithm>
#include<iterator>
#include<iomanip>
#include<set>
#include<vector>
using namespace std;
int main()
{
    int N;
    while(cin >> N)
    {
        //input data
       vector<set<int>> sets(N + 1);
       for(int i = 1;i <= N;i++)
       {
           int M;
           cin >> M;
           for(int j = 0;j < M;j++)
           {
               int value;
               cin >> value;
               sets[i].insert(value);
           }
       }
       //output
       int K,first,second;

       cin >> K;
       for(int j = 0;j < K;j++)
       {
           cin >> first;
           cin >> second;
           set<int> u;
           set<int> i;

           set_union(sets[first].begin(),sets[first].end(),sets[second].begin(),sets[second].end(),inserter(u,u.begin())); //union
           set_intersection(sets[first].begin(),sets[first].end(),sets[second].begin(),sets[second].end(),inserter(i,i.begin())); //intersection

           double t = u.size();
           double c = i.size();
           cout << fixed << setprecision(1) << c/t*100 << "%" << endl;
       }
    }
}

 

 

PAT1063:Set Similarity

标签:tle   print   class   test   one   name   algorithm   i++   log   

原文地址:http://www.cnblogs.com/0kk470/p/7629256.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!