码迷,mamicode.com
首页 > 其他好文 > 详细

poj1007 DNA Sorting

时间:2017-10-06 14:20:29      阅读:212      评论:0      收藏:0      [点我收藏+]

标签:first   分享   false   思路   org   number   bool   each   class   

Description

One measure of ``unsortedness‘‘ in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC‘‘, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG‘‘ has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM‘‘ has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness‘‘, from ``most sorted‘‘ to ``least sorted‘‘. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted‘‘ to ``least sorted‘‘. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

题意:按逆序数大小排序。
思路:sort自定义cmp()。
技术分享
#include<iostream>
#include<algorithm>
using namespace std;
struct dna
{
    char s[55];
    int sum;
};
struct dna d[105];
bool cmp(const struct dna& a,const struct dna& b)
{
    if(a.sum<b.sum) return true;
    else    return false;
}

int main()
{
    int n,m;
    cin>>n>>m;
    for(int i=0; i<m; i++)
    {
        cin>>d[i].s;
    }
    for(int i=0; i<m; i++)
    {
        for(int j=0; j<n; j++)
        {
            for(int k=j+1; k<n; k++)
            {
                if(d[i].s[j]>d[i].s[k])
                d[i].sum++;
            }
        }
        //cout<<d[i].sum<<endl;
    }
    sort(d,d+m,cmp);
    cout<<d[0].s;
    for(int i=1; i<m; i++)
    {
        cout<<\n<<d[i].s;
    }
    return 0;
}
View Code

 

poj1007 DNA Sorting

标签:first   分享   false   思路   org   number   bool   each   class   

原文地址:http://www.cnblogs.com/seaupnice/p/7631479.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!