码迷,mamicode.com
首页 > 其他好文 > 详细

PAT1113: Integer Set Partition

时间:2017-10-06 18:36:34      阅读:131      评论:0      收藏:0      [点我收藏+]

标签:namespace   name   tee   include   and   emc   less   --   font   

1113. Integer Set Partition (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a set of N (> 1) positive integers, you are supposed to partition them into two disjoint sets A1 and A2 of n1 and n2numbers, respectively. Let S1 and S2 denote the sums of all the numbers in A1 and A2, respectively. You are supposed to make the partition so that |n1 - n2| is minimized first, and then |S1 - S2| is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2 <= N <= 105), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 231.

Output Specification:

For each case, print in a line two numbers: |n1 - n2| and |S1 - S2|, separated by exactly one space.

Sample Input 1:
10
23 8 10 99 46 2333 46 1 666 555
Sample Output 1:
0 3611
Sample Input 2:
13
110 79 218 69 3721 100 29 135 2 6 13 5188 85
Sample Output 2:
1 9359

思路

水题--
1.先求min|n1-n2|
N为奇数时|n1-n2| = 1,反之|n1-n2| = 0;
2.由min|n1-n2| => max|S1-S2|
可以先把输入的数组num排序,然后令s1是num的前(N/2 - 1)个数的和,S2是num剩下数的和,此时|S1-S2|最小。

代码
#include<iostream>
#include<vector>
#include<algorithm>
#include<math.h>
using namespace std;
int main()
{
   int N;
   while(cin >> N)
   {
     int n = N % 2;
     vector<int> nums(N);
     for(int i = 0;i < N;i++)
     {
         cin >> nums[i];
     }
     sort(nums.begin(),nums.end());
     int s1 = 0,s2 = 0;
     int index = N/2 - 1;
     for(int i = 0;i <= index;i++)
     {
         s1 += nums[i];
     }
     for(++index;index < N;index++)
     {
         s2 += nums[index];
     }

     cout << n << " " << abs(s1-s2) << endl;
   }
}

 

PAT1113: Integer Set Partition

标签:namespace   name   tee   include   and   emc   less   --   font   

原文地址:http://www.cnblogs.com/0kk470/p/7631909.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!