标签:sts res can logs setup targe 子序列 ted --
Wooden Sticks
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 24062 |
|
Accepted: 10369 |
Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l‘ and weight w‘ if l <= l‘ and w <= w‘. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
2
1
3
Source
题意:
给出n个二元组(a,b),将这n个二元组分成k个部分,每个部分内ai+1>=ai && bi+1>=bi
问最少划分数
先将给出的二元组从小到大排序
定义(A,≤)是偏序集,≤ 表示 xi+1>=xi && yi+1>=yi
那么根据 Dilworth 定理 及其 对偶定理
定理1 令(X,≤)是一个有限偏序集,并令r是其最大链的大小。则X可以被划分成r个但不能再少的反链。
定理2 令(X,≤)是一个有限偏序集,并令m是反链的最大的大小。则X可以被划分成m个但不能再少的链。
这里最少划分数即为最少链数=最大反链长度
即答案=最长严格递减子序列长度
#include<cstdio>
#include<iostream>
#include<algorithm>
#define N 5001
using namespace std;
struct node
{
int a,b;
}e[N];
int s,f[N];
bool cmp(node p,node q)
{
if(p.a!=q.a) return p.a<q.a;
return p.b<q.b;
}
int find(int w)
{
int l=1,r=s,mid,tmp=-1;
while(l<=r)
{
mid=l+r>>1;
if(f[mid]<=w) tmp=mid,r=mid-1;
else l=mid+1;
}
return tmp;
}
int main()
{
int T,n,pos;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for(int i=1;i<=n;i++) scanf("%d%d",&e[i].a,&e[i].b);
sort(e+1,e+n+1,cmp);
f[s=0]=2e9;
for(int i=1;i<=n;i++)
if(e[i].b<f[s]) f[++s]=e[i].b;
else
{
pos=find(e[i].b);
if(pos>0) f[pos]=e[i].b;
}
printf("%d\n",s);
}
}
poj 1065 Wooden Sticks
标签:sts res can logs setup targe 子序列 ted --
原文地址:http://www.cnblogs.com/TheRoadToTheGold/p/7644715.html