码迷,mamicode.com
首页 > 其他好文 > 详细

PAT1048:Find Coins

时间:2017-10-11 20:26:45      阅读:155      评论:0      收藏:0      [点我收藏+]

标签:ane   题目   inf   长度   ble   while   cin   payment   lov   

1048. Find Coins (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.

Sample Input 1:
8 15
1 2 8 7 2 4 11 15
Sample Output 1:
4 11
Sample Input 2:
7 14
1 8 7 2 4 11 15
Sample Output 2:
No Solution

思路

1.用桶排序的方式来存放输入的数。
2.遍历时从最小数v1开始,然后检查v2 = M - v1是否存在,没有则继续遍历直到nums[v2]存在,这时就得到满足题目要求的最小数v1,且v1 + v2 = M。

代码
#include<iostream>
#include<vector>
using namespace std;


int main()
{
  int N,value;
  while(cin >> N >> value)
  {
      vector<int> nums(1000,0);
      for(int i = 0;i < N;i++)
      {
          int number;
          cin >> number;
          nums[number]++;
      }

      for(int i = 0;i < 1000;i++)
      {
          if(nums[i] > 0)
          {
            nums[i]--;
            if(value > i && nums[value - i] > 0)
            {
              cout << i << " " << value - i << endl;
              return 0;
            }
            nums[i]++;
          }

      }
      cout << "No Solution" << endl;
  }
}

 

PAT1048:Find Coins

标签:ane   题目   inf   长度   ble   while   cin   payment   lov   

原文地址:http://www.cnblogs.com/0kk470/p/7652438.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!