码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1003:Max Sum

时间:2017-10-12 10:17:39      阅读:130      评论:0      收藏:0      [点我收藏+]

标签:存在   ber   position   size   contains   print   tar   contain   code   

HDU1003:Max Sum

同51NOD1049

最大连续子段和(存在最大负整数和(-1000))

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 258263    Accepted Submission(s): 61372


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

 

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
题意:最大连续子段和()
注意:存在最大负整数和(-1000)
思路:直接从前向后扫 复杂度 O(n)
/* 最大连续子段和 */ 
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std ; 

#define maxn 110000
int n ; 
int max_sum ; 
int num[maxn] ; 
int st1 , st2 ; 
int result ; 

int main(){
    int t ; 
    scanf("%d" , &t) ; 
    for(int times = 1 ; times <= t ; times ++ ){
        scanf("%d" , &n) ; 
        for(int i=1 ; i<= n ; i++){
            scanf("%d" , &num[i]) ; 
        }
        max_sum = -1 ; 
        result = -100000 ; //可能会出现 最大和 为 负数的情况  
        int k ; 
        for(int i=1 ; i<=n ; i++){ 
            if(max_sum < 0 ){
                max_sum = 0 ; 
                k = i ; 
            }
            max_sum += num[i] ; 
            if(max_sum > result){ // 找到一个较大和  更新值  , result初始值较小 保证存在负数最大和(-1000) 
                result = max_sum ; 
                st1 = k ; 
                st2 = i ; 
            }
        }
        printf("Case %d:\n" , times ) ; 
        printf("%d %d %d\n" , result , st1 , st2) ; 
        if(times!=t) printf("\n")  ; // 注意格式 
    }
    return 0 ; 
}

 

HDU1003:Max Sum

标签:存在   ber   position   size   contains   print   tar   contain   code   

原文地址:http://www.cnblogs.com/yi-ye-zhi-qiu/p/7653673.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!