码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1491 Octorber 21st(数学题)

时间:2014-09-11 09:40:51      阅读:235      评论:0      收藏:0      [点我收藏+]

标签:hdu   数学   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1491


Problem Description
HDU‘s 50th birthday, on Octorber 21st, is coming. What an exciting day!! As a student of HDU, I always want to know how many days are there between today and Octorber 21st.So, write a problem and tell me the answer.Of course, the date I give you is always in 2006.

bubuko.com,布布扣

 

Input
The input consists of T test cases. The number of T is given on the first line of the input file.Following T lines, which represent dates, one date per line. The format for a date is "month day" where month is a number between 1 (which indicates January) and 12 (which indicates December), day is a number between 1 and 31.All the date in the input are in 2006, you can assume that all the dates in the input are legal(合法).
 

Output
For each case, if the date is before Octorber 21st, you should print a number that between the date and Octorber 21st.If the day is beyond Octorber 21st, just print "What a pity, it has passed!".If the date is just Octorber 21st, print"It‘s today!!".
 

Sample Input
7 10 20 10 19 10 1 10 21 9 1 11 11 12 12
 

Sample Output
1 2 20 It‘s today!! 50 What a pity, it has passed! What a pity, it has passed!
 

Author
8600
 

Source


代码如下:

#include <cstdio>
int mon(int x)
{
    if(x == 1)
        return 31;
    else if(x == 2)
        return 28;
    else if(x == 3)
        return 31;
    else if(x == 4)
        return 30;
    else if(x == 5)
        return 31;
    else if(x == 6)
        return 30;
    else if(x == 7)
        return 31;
    else if(x == 8)
        return 31;
    else if(x == 9)
        return 30;
}
int main()
{
    int t;
    int m, d;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&m,&d);
        if(m == 10 && d == 21)
        {
            printf("It's today!!\n");
            continue;
        }
        if(m>10 ||(m==10&&d>21))
        {
            printf("What a pity, it has passed!\n");
            continue;
        }
        int sum = 0;
        for(int i = m; i < 10; i++)
        {
            sum+=mon(i);
        }
        printf("%d\n",sum-d+21);
    }
    return 0;
}



hdu 1491 Octorber 21st(数学题)

标签:hdu   数学   

原文地址:http://blog.csdn.net/u012860063/article/details/39201991

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!