码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1004:Let the Balloon Rise

时间:2017-10-13 00:30:15      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:col   pre   ota   12px   ora   nes   ted   ane   memory   

HDU1004:Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 127904    Accepted Submission(s): 50515


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges‘ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

 

Sample Input
5 green red blue red red 3 pink orange pink 0
 

 

Sample Output
red pink
题意:输出单词数组里出现最多的单词
思路:新单词存字符串数组,同时统计单词个数的数组dp[pos] = 1 ; 旧单词(已经出现过得) dp[pos]++ ;
  最后 扫一下 dp数组 找出最大值(单词出现次数)最多的下边 , 输出str数组对应的 单词
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <map>

using namespace std ;

#define maxn 2000  
char num[30] , str[maxn][30] ; 

int dp[maxn] ; 

int main(){
    int t ; 
     
    while(~scanf("%d" , &t) && t!=0){
        int total = 0 ; 
        memset(dp , 0 , sizeof(dp)) ;         
        for(int i=0 ; i<t ; i++){
            scanf("%s" , num) ;
            int flag = 0 ; 
            for(int j=0 ; j< total ; j++){
                if(!strcmp(num , str[j])){
                    dp[j] ++ ; 
                    flag =1 ; 
                }
            } 
            if(!flag){
                strcpy(str[total] , num) ; 
                dp[total] ++ ; 
                total ++ ; 
            }
        } 
        int max_num = -1 ; 
        int max_flag ;  
        for(int i=0 ; i<total ; i++){
            if(dp[i] > max_num){
                max_num = dp[i] ; 
                max_flag = i ; 
            }
        }
        printf("%s\n" , str[max_flag]) ; 
    }
    return 0 ; 
}  

 

HDU1004:Let the Balloon Rise

标签:col   pre   ota   12px   ora   nes   ted   ane   memory   

原文地址:http://www.cnblogs.com/yi-ye-zhi-qiu/p/7658597.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!