码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2767 Proving Equivalences (Tarjan)

时间:2017-10-14 18:24:59      阅读:224      评论:0      收藏:0      [点我收藏+]

标签:addition   ext   center   text   near   nal   matrix   证明   finally   

Proving Equivalences

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 3   Accepted Submission(s) : 1

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.
2. Ax = b has exactly one solution for every n × 1 matrix b.
3. Ax = b is consistent for every n × 1 matrix b.
4. Ax = 0 has only the trivial solution x = 0. 

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

Output

Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

Sample Input

2
4 0
3 2
1 2
1 3

Sample Output

4
2

Source

NWERC 2008
 
题目大意:
a 证明 b,且,b 证明 a,说明a和b相等
a证明b,b证明c,可以得出 a 证明 c。 
求最少再证明几次才能使得这些题都能互相证明
题解:
用Tarjan缩点,然后答案就是 max(入度=0,出度=0)。
#include<bits/stdc++.h>
using namespace std;
int n,T,m,index,team_num;
int low[20005],dfn[20005],team[20005],in[20005],out[20005];
bool instack[20005];
vector<int> mp[20005];
stack<int> S;
void Tarjan ( int u )
{
    dfn[u]=low[u]=++index;
    S.push(u);
    instack[u]=1;
    for ( int i=0;i<mp[u].size();i++)
    {
        int v=mp[u][i];
        if (!dfn[v])
        {
            Tarjan (v) ;
            low[u]=min(low[u],low[v]);
        }
        else if (instack[v]) low[u]=min(low[u],dfn[v]);//是否在栈中
    }
    if (dfn[u]==low[u])  //构成强连通分量
    {
        team_num++; //组数
        while (1)   //同一组标号
        {
            int v=S.top(); S.pop();
            instack[v]=0;
            team[v]=team_num;
            if (v==u) break;
        }
    }
}

void dfs()
{
    memset(team,0,sizeof(team));
    memset(dfn,0,sizeof(dfn));
    memset(low,0,sizeof(low));
    memset(instack,0,sizeof(instack));
    team_num=0;
    index=0;
    for(int i=1;i<=n;i++)
        if (!dfn[i]) Tarjan(i);
}

int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++) mp[i].clear();
        for(int i=1;i<=m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            mp[x].push_back(y);
        }
        dfs(); //缩点
        /*for(int i=1;i<=n;i++)
            printf("%d:%d\n",i,team[i]);*/

       for(int i=1;i<=team_num;i++) in[i]=out[i]=0;
       for(int i=1;i<=n;i++)
        for(int j=0;j<mp[i].size();j++)
        {
             if (team[i]!=team[mp[i][j]])
             {
                 out[ team[i] ]++;
                 in[ team[mp[i][j]] ]++;
             }
        }
        int innum=0,outnum=0;
        for(int i=1;i<=team_num;i++)
        {
           if (!in[i]) innum++;
           if (!out[i]) outnum++;
        }
        if (team_num==1) printf("0\n");
          else printf("%d\n",max(innum,outnum));
    }
    return 0;
}

 

HDU 2767 Proving Equivalences (Tarjan)

标签:addition   ext   center   text   near   nal   matrix   证明   finally   

原文地址:http://www.cnblogs.com/stepping/p/7667809.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!