标签:span dea tis miss contains gcd ges recommend any
GCD
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2437 Accepted Submission(s): 1253
Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
Output
For each test case,output the answer on a single line.
Sample Input
Sample Output
Source
Recommend
lcy
题目大意:求sigma (i=1--n)gcd(i,n)>=m的数的个数
题解:
问题sigma(i=1--n)gcd(i,n)>=m的数的个数,设d=gcd(i,n),
根据题目的要求d>=m&&d|n.
所以我们要求sigma(d>=m&&d|n)sigma(i=1--n)gcd(n,i)==d
变形就是sigma(d>=m&&d|n)sigma(i=1--n)gcd(n/d,i/d)==1的数
的个数,那么d是枚举的,n/d是已知的,gcd(n/d,i/d)==1的个数
就是phi(n/d)。
代码:hdu炸了没测
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int t,n,m;
int euler(int x){
int ret=x;
for(int i=2;i*i<=x;i++){
if(x%i==0){
ret=ret/i*(i-1);
while(x%i==0)x/=i;
}
}
if(x>1)ret=ret/x*(x-1);
return ret;
}
int main(){
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&m);
int ans=0;
for(int i=1;i*i<=n;i++){
if(n%i==0){
// cout<<euler(n/i)<<" "<<euler(i)<<endl;
if(i>=m)ans=ans+euler(n/i);
if(n/i>=m&&i*i!=n)ans=ans+euler(i);
}
}
printf("%d\n",ans);
}
return 0;
}
[HDU2588]GCD 欧拉函数
标签:span dea tis miss contains gcd ges recommend any
原文地址:http://www.cnblogs.com/zzyh/p/7668406.html