码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1087:Super Jumping! Jumping! Jumping!(上升子序列最大和)

时间:2017-10-15 21:25:44      阅读:190      评论:0      收藏:0      [点我收藏+]

标签:专题   最长上升子序列   visit   weight   marked   note   efi   memset   about   

HDU1087:Super Jumping! Jumping! Jumping!

kuangbin专题十二:E题

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41625    Accepted Submission(s): 19291


Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

技术分享


The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

 

Output
For each case, print the maximum according to rules, and one line one case.
 

 

Sample Input
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

 

Sample Output
4 10 3
 
题意:在给出的数字序列中,找出一个子序列  满足(1)顺序上升 (2)上升序列求和最大
思路:最长上升子序列改一下就好了
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>

using namespace  std ; 

#define maxn 2000 
int num[maxn] ; 
int dp[maxn] ; 

int main(){
    int n ; 
    while(~scanf("%d" , &n) && n ){
        memset(dp , 0 ,  sizeof(dp)) ; 
        for(int i=1 ; i<=n ; i++){
            scanf("%d" , &num[i]) ; 
            dp[i] = num[i] ; 
            // 初始(子)状态  每一个单独的数字 都可以看成一个 上升子序列 
        }
        
        int max_num = dp[1] ; 
        for(int i=1 ; i<=n ; i++){
            for(int j=1 ; j<i ; j++){
                if(num[j] < num[i]){
                    dp[i] = max(dp[i] , dp[j] + num[i]) ; 
                    if(dp[i] > max_num){
                        max_num = dp[i] ;
                    }
                }
            }
        }
        printf("%d\n" , max_num ) ; 
    }    
    
    return 0 ; 
}

 

 

HDU1087:Super Jumping! Jumping! Jumping!(上升子序列最大和)

标签:专题   最长上升子序列   visit   weight   marked   note   efi   memset   about   

原文地址:http://www.cnblogs.com/yi-ye-zhi-qiu/p/7673829.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!