码迷,mamicode.com
首页 > 其他好文 > 详细

IO-09. 计算摄氏温度

时间:2014-09-11 18:48:52      阅读:340      评论:0      收藏:0      [点我收藏+]

标签:style   blog   color   io   java   ar   strong   div   sp   

 

给定一个华氏温度F,本题要求编写程序,计算对应的摄氏温度C。计算公式:C = 5*(F-32)/9。题目保证输入与输出均在整型范围内。

输入格式:输入在一行中给出一个华氏温度。

输出格式:在一行中按照格式“Celsius = C”输出对应的摄氏温度C的整数值。

输入样例:150

输出样例:Celsius = 65

import java.util.Scanner;
 public class Main {
     public static void main(String[] args)
      {
          Scanner F = new Scanner(System.in);
          int f = F.nextInt();
          int C = (int) 5*(f-32)/9;//强制转换成int
          System.out.printf("Celsius = "+C);
      //System.out.printf("Celsius = %d",C);这种也行。
        }
}

 

IO-09. 计算摄氏温度

标签:style   blog   color   io   java   ar   strong   div   sp   

原文地址:http://www.cnblogs.com/lsgcoder101/p/3966783.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!