码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2492 A Bug's Life

时间:2014-09-11 19:22:22      阅读:154      评论:0      收藏:0      [点我收藏+]

标签:algorithm   并查集   acm   poj   向量并查集   


题目来源:http://poj.org/problem?id=2492


A Bug‘s Life
Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 28494   Accepted: 9286

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs‘ sexual behavior, or "Suspicious bugs found!" if Professor Hopper‘s assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

Source

TUD Programming Contest 2005, Darmstadt, Germany

题解:向量并查集----搞基问题


AC代码:

#include<cstdio>
int c,m,n,father[2001],x,y;
bool r[2001],flag,s,t;
int find(int k,bool &f){
	if(k==father[k]){
		f=false; return k;
	}
	int temp;
	temp=find(father[k],f);
	f=r[k]^f;
	return temp;
}
int main(){
	scanf("%d",&c);
	for(int k=1;k<=c;k++){
		flag=true;
		scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++){
		father[i]=i; r[i]=false;
	}	
	for(int i=0;i<m;i++){
		scanf("%d%d",&x,&y);
		if(flag){
			x=find(x,s=false);
			y=find(y,t=false);
			if(x==y)	flag=s^t;
			else {
				father[x]=y;
				r[x]=!(s^t);
			}
		}
	}
	if(flag)  printf("Scenario #%d:\nNo suspicious bugs found!\n\n",k);
	else printf("Scenario #%d:\nSuspicious bugs found!\n\n",k);
	}
	return 0;
} 







POJ 2492 A Bug's Life

标签:algorithm   并查集   acm   poj   向量并查集   

原文地址:http://blog.csdn.net/mummyding/article/details/39209945

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!