码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1014 Dividing 母函数

时间:2014-09-11 19:31:22      阅读:197      评论:0      收藏:0      [点我收藏+]

标签:组合数学

Dividing
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 59666   Accepted: 15417

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000. 
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can‘t be divided.". 
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 

Sample Output

Collection #1:
Can‘t be divided.

Collection #2:
Can be divided.

Source


题目大意:每行给出6个数,第 i 个数代表价值为 i 的石头的个数,问这么多个石头两个人能不能平均分。

就是一道简单的母函数,首先可先把石头的总价值sum算出来,如果sum是奇数,那么就不能平均分,如果是偶数,利用母函数的知识,只需判断指数为 sum/2 的系数是否为零,如果为0,说明没有一种方案可以平均分;如果不为0,则可以。

需要说明的是,由于每种价值的石头的个数可能很大,这有一个定理:对于任何一种石头的个数n,如果n大于等于8,则可将n改写成11(n为奇数)或12(n为偶数)。  否则会超时。

#include <stdio.h>
#include <string.h>
#include <math.h>

int c[200005],d[200005];

int main()
{
	int i,j,sum,k,cas=1,f[8];
	while(1)
	{
		sum=0;
		for(i=1;i<=6;i++)
		{
			scanf("%d",&f[i]);
			if(f[i]>=8)
			{
				if(f[i]%2)
					f[i]=11;
				else
					f[i]=12;
			}
			sum+=f[i]*i;
		}
		if(sum==0)
			break;
		if(sum%2)
		{
			printf("Collection #%d:\nCan't be divided.\n\n",cas++);
			continue;
		}
		memset(c,0,sizeof(c));
		memset(d,0,sizeof(d));
		c[0]=1;
		sum=sum/2;
		for(i=1;i<=6;i++)
		{
			for(j=0;j<=sum;j++)
				for(k=0;k<=f[i] && k*i+j<=sum;k++)
					d[k*i+j]+=c[j];
			memcpy(c,d,sizeof(d));
			memset(d,0,sizeof(d));
		}
		if(c[sum])
			printf("Collection #%d:\nCan be divided.\n\n",cas++);
		else 
			printf("Collection #%d:\nCan't be divided.\n\n",cas++);
	}
	return 0;
}

注意输出格式,最后有空行。

POJ1014 Dividing 母函数

标签:组合数学

原文地址:http://blog.csdn.net/u013068502/article/details/39208525

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!