码迷,mamicode.com
首页 > 其他好文 > 详细

USACO 2006 November Gold Corn Fields

时间:2017-10-21 16:29:16      阅读:181      评论:0      收藏:0      [点我收藏+]

标签:isl   down   max   close   时间   possible   term   some   lan   

USACO 2006 November Gold Corn Fields

题目描述:

Farmer John has purchased a lush new rectangular pasture composed of M by N square parcels. He wants to grow some yummy corn for the cows on a number of squares.

Regrettably, some of the squares are infertile and can‘t be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option!  Please help Farmer John determine the number of ways he can choose the squares to plant.

输入格式:

* Line 1: Two space-separated integers: M and N

* Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0  for infertile)

输出格式:

* Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

样例输入:

2 3
1 1 1
0 1 0

样例输出:

9

提示:

【样例解释】

Number the squares as follows:

1 2 3

  4

There are four ways to plant only on one squares (1, 2, 3, or 4),

three ways to plant on two squares (13, 14, or 34), 1 way to plant

on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

【数据规模】

1<=M<=12;1<=N<=12

时间限制:1000ms
空间限制:256MByte

 

 

又水了一道题,地图记得反着存就好了。。。别忘了%%%kcz!!!

唉,最近kcz在玩pku的游戏挑战赛,我们这些小蒟蒻只有刷水题的份了,QAQ——

#include<bits/stdc++.h>
#define ll long long
#define kcz 100000000
using namespace std;

ll f[14][1 << 14] , m , n , maxn;
ll s [14][14];

ll check(ll now , ll down)
{
    if((down << 1) & down || (down >> 1) & down) return 0;
    for(ll i=0;i<m;i++)
    {
        ll ce = 1 << i;
        if(now & ce && down & ce) return 0;
    }
    return 1;
}

ll find(ll pos , ll val)
{
    for(ll i=0;i<m;i++)
    {
        ll ce = 1 << i;
        if(val & ce && s[pos][i]) return 0;
    }
    return 1;
}

int main(){
    cin >> n >> m;
    for(ll i=1;i<=n;i++)    
        for(ll j=0;j<m;j++)
        {
            
            scanf("%lld",&s[i][j]);
            s[i][j] ^= 1;
        }
    maxn = 1 << m;
    f[0][0] = 1;
    for(ll i=0;i<n;i++)
        for(ll j=0;j<maxn;j++)
        {
            if(f[i][j])
            {
                for(ll k=0;k<maxn;k++)
                    if(check(j , k) && find(i + 1 , k))
                        f[i + 1][k] += f[i][j];
            }
        }
    ll ans = 0;
    for(ll i=0;i<maxn;i++)
    {
        ans += f[n][i];
        ans %= kcz;
    }
    cout << ans;
}

 

USACO 2006 November Gold Corn Fields

标签:isl   down   max   close   时间   possible   term   some   lan   

原文地址:http://www.cnblogs.com/kczno1fans/p/7703534.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!