码迷,mamicode.com
首页 > 其他好文 > 详细

1035. Password (20)

时间:2017-10-22 11:08:21      阅读:143      评论:0      收藏:0      [点我收藏+]

标签:clu   nts   one   res   return   modified   scanf   int   string   

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

 

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However, if N is one, you must print "There is 1 account and no account is modified" instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified


#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
struct Account{
	char name[12];
	char password[12];
	int flag;
};
Account account[1002];
int main(){
	int n;
	int i,j,flag=0;
	int sum = 0;
	scanf("%d",&n);
	for(i=0;i<n;i++){
		scanf("%s%s",account[i].name,account[i].password);
		int length = strlen(account[i].password);
		for(j=0;j<length;j++){
			if(account[i].password[j] == ‘1‘){
				account[i].password[j]=‘@‘;
				flag = 1;
			}else if(account[i].password[j]==‘0‘){
				account[i].password[j]=‘%‘;
				flag = 1;
			}else if(account[i].password[j]==‘l‘){
				account[i].password[j]=‘L‘;
				flag = 1;
			}else if(account[i].password[j]==‘O‘){
				account[i].password[j]=‘o‘;
				flag = 1;
			}
		}
		if(flag == 1){
			sum++;
		}
		account[i].flag=flag;
		flag = 0;
	}
	if(sum == 0 && n > 1){
		printf("There are %d accounts and no account is modified\n",n);
	}else if(sum == 0 && n == 1){
		printf("There is 1 account and no account is modified\n");
	}else{
		printf("%d\n",sum);
		for(i=0;i<n;i++){
			if(account[i].flag == 1){
				printf("%s %s\n",account[i].name,account[i].password);
			}
		}
	}
	return 0;
}

  

1035. Password (20)

标签:clu   nts   one   res   return   modified   scanf   int   string   

原文地址:http://www.cnblogs.com/grglym/p/7707919.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!