码迷,mamicode.com
首页 > 其他好文 > 详细

1041. Be Unique (20)

时间:2017-10-23 21:40:11      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:who   cst   one   cstring   inpu   memset   pac   hose   ==   

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main(){
	int n;
	int num[10002];
	int a[100002];
	memset(num,0,sizeof(num));
	int i;
	scanf("%d",&n);
	for(i=0;i<n;i++){
		scanf("%d",&a[i]);
		num[a[i]]++;
	}
	int flag=0;
	for(i=0;i<n;i++){
		if(num[a[i]]==1){
			printf("%d\n",a[i]);
			flag=1;
			break;
		}
	}
	if(flag==0){
		printf("None\n");
	}
	return 0;
} 

  

1041. Be Unique (20)

标签:who   cst   one   cstring   inpu   memset   pac   hose   ==   

原文地址:http://www.cnblogs.com/grglym/p/7718753.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!