码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1750 Dictionary(模拟)

时间:2014-09-12 01:16:12      阅读:276      评论:0      收藏:0      [点我收藏+]

标签:poj   模拟   

题目链接:http://poj.org/problem?id=1750


Description

Authors of the new, all-in-one encyclopedia have organized the titles in the order they consider most appropriate for their readers. It‘s not always alphabetical, because they want to observe some peculiar relationships between them. However, they still want to allow users to look up titles quickly. 

They achieve this by adding a carefully calculated number of spaces before every title in the list of titles. They call this structure a dictionary. 

A dictionary is represented by a list of words with some number of spaces before certain words. Dictionary format can be described as a set of constraints on sequences of consecutive words starting with the same letter. Any maximal sequence of consecutive words starting with the same letter should satisfy the following rules: 

  • The first word in the group has no spaces before it. Every subsequent word in the group has at least one leading space. 
  • If 
    • the first word of the group is deleted and 
    • one space is deleted before every remaining word and 
    • the first letter is deleted from every remaining word

    then resulting sequence is a dictionary.

The authors don‘t feel like giving you a more detailed explanation of what a dictionary is, so they have included an example (see sample input and output) that clarifies their definition. 
Your task is to write a program that will convert a given list of words into a dictionary by adding some number of spaces before certain words and preserving the original order of the words. 

Input

The input consists of at least one and most 100000 words. Each word consists of at least one and at most 10 lower-case letters. There will be no leading or trailing spaces. There will be no blank lines between the words, but there may be an arbitrary number of blank lines at the end of the file.

Output

Write to the output the original words in the same order without any trailing spaces but with the appropriate number of leading spaces, so that this word list is a dictionary. There should be no blank lines between the words, but there may be an arbitrary number of blank lines at the end of the file.

Sample Input

a
ant
antique
amaze
bargain
bridge
bride
bribe
born
bucket
tart
tan
tram
trolley
t
try
trial
zed
double
dorm
do
dormant
donate
again
agony
boost
back
born

Sample Output

a
 ant
  antique
 amaze
bargain
 bridge
  bride
   bribe
 born
 bucket
tart
 tan
 tram
  trolley
 t
 try
  trial
zed
double
 dorm
  do
  dormant
  donate
again
 agony
boost
 back
 born

Source


题意:

比较每个字符串与前面的字符串相同的字符的个数,如果相同的字符的个数比上一字符串与上上一个字符串相同的字符多,那么就让此字符串前面,在上一字符串已有的空格的基础上多增加一个空格,相反如果是小于,那么就按照当前相同的字符打印空格,PS:说得不明不白的,具体见代码就懂了!


代码如下:

#include <cstdio>
#include <cstring>
int main()
{
    char s1[17], s2[17];
    int tt=0;
    while(gets(s2))
    {
        int i=0,j=0;
        int len1 = strlen(s1);
        int len2 = strlen(s2);
        while(i<len1 && j<len2)
        {
            if(s1[i] == s2[j])
            {
                i++;
                j++;
            }
            else
                break;
        }
        if(i <= tt)
            tt = i;
        if(i > tt)
            tt += 1;
        strcpy(s1,s2);
        for(int i = 0; i < tt; i++)
            printf(" ");
        printf("%s\n",s2);
    }
    return 0;
}


POJ 1750 Dictionary(模拟)

标签:poj   模拟   

原文地址:http://blog.csdn.net/u012860063/article/details/39215935

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!