码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1751 Highways

时间:2014-09-12 11:59:33      阅读:206      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   for   

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can‘t reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length. 

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. 

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of ith town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. 

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway. 

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space. 

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty. 

Sample Input

9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7

8 3

题意:给你一些点的坐标,其中有k条路是已经连通了,现在要你求出所需最小生成树的边

思路:先用并查集去把已经连在一起的点放到一个集合里面去,然后再用最小生成树算法

这个思路在CF Getting ready for ACM-ICPC 2014-2015: weekly trainings on Codeforces比赛上根本就过不了,但是在POJ上能过。如果在当时的比赛能过的,求大神来指导一下思路! ORZ!

#include<stdio.h>
#include<algorithm>
using namespace std;
const int  M=5000000+10;
const int  N=10000+10;
int f[N];
int x[N],y[N];
int n,cnt;
struct p
{
    int u,v,w;
}num[M];

bool cmp(p x,p y)
{
    return x.w<y.w;
}
int find(int x)
{
    if(x!=f[x])
        f[x]=find(f[x]);
    return f[x];
}
int juli(int i,int j)
{
    return (x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]);
}
void kruskal()
{
    int i,tot=0;
    for(i=0;i<cnt&&tot<n-1;i++)
    {
        int a=find(num[i].u);
        int b=find(num[i].v);
        if(a==b)
            continue;

        printf("%d %d\n",num[i].u,num[i].v);
        f[a]=b;
        tot--;
    }
}
int main()
{
    int i,j,k,a,b;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
            scanf("%d %d",&x[i],&y[i]);
    scanf("%d",&k);
    for(i=0;i<=n;i++)
        f[i]=i;
    for(i=0;i<k;i++)
    {
        scanf("%d%d",&a,&b);
        a=find(a);
        b=find(b);
        if(a!=b)
            f[a]=b;
    }
    cnt=0;
    for(i=1;i<=n;i++)
    {
            for(j=i+1;j<=n;j++)
            {
                int a,b;
                a=find(i);
                b=find(j);
                if(a==b)
                    continue;
                num[cnt].u=i;
                num[cnt].v=j;
                num[cnt++].w=juli(i,j);
            }
    }
    sort(num,num+cnt,cmp);
    kruskal();

    return 0;
}


POJ 1751 Highways

标签:des   style   blog   http   color   io   os   ar   for   

原文地址:http://blog.csdn.net/u012313382/article/details/39227359

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!