码迷,mamicode.com
首页 > 其他好文 > 详细

1031. Hello World for U

时间:2017-10-27 23:05:00      阅读:180      评论:0      收藏:0      [点我收藏+]

标签:限制   har   ble   script   vertica   ++   one   like   break   

1031. Hello World for U (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

 

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h   !
e   d
l   l
lowor

import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner  in=new Scanner(System.in);
        String n=in.nextLine();
        int num=n.length();
        int n1,n3,x = 0,y = 0;
        for(n3=3;n3<=num;n3++){
            for(n1=n3;n1>=0;n1--){
                //System.out.println(n1+" "+n3+" "+(2*n1+n3-2)+" "+num);
                if(2*n1+n3-2==num){
                    x=n1;
                    y=n3;
                    break;
                }
                if(x!=0&&y!=0) break;
            }
        }
        //System.out.println(num+" "+x+" "+y);
        for(int i=0,j=num-1;i<x-1;i++,j--){
            System.out.print(n.charAt(i));
            for(int k=0;k<y-2;k++)
            {
                System.out.print(" ");
            }
            System.out.println(n.charAt(j));
        }
        for(int i=x-1;i<x-1+y;i++){
            System.out.print(n.charAt(i));
        }
    }

}

 

1031. Hello World for U

标签:限制   har   ble   script   vertica   ++   one   like   break   

原文地址:http://www.cnblogs.com/chen20135517/p/7745499.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!