码迷,mamicode.com
首页 > 其他好文 > 详细

【水】wikioi1073 家族

时间:2014-09-12 15:02:23      阅读:184      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   strong   for   

1073 家族

 时间限制: 1 s
 空间限制: 128000 KB
 题目等级 : 大师 Master
 

题目描述 Description

若某个家族人员过于庞大,要判断两个是否是亲戚,确实还很不容易,现在给出某个亲戚关系图,求任意给出的两个人是否具有亲戚关系。 规定:x和y是亲戚,y和z是亲戚,那么x和z也是亲戚。如果x,y是亲戚,那么x的亲戚都是y的亲戚,y的亲戚也都是x的亲戚。

输入描述 Input Description

第一行:三个整数n,m,p,(n<=5000,m<=5000,p<=5000),分别表示有n个人,m个亲戚关系,询问p对亲戚关系。 以下m行:每行两个数Mi,Mj,1<=Mi,Mj<=N,表示Ai和Bi具有亲戚关系。 接下来p行:每行两个数Pi,Pj,询问Pi和Pj是否具有亲戚关系。

输出描述 Output Description

P行,每行一个’Yes’或’No’。表示第i个询问的答案为“具有”或“不具有”亲戚关系。

样例输入 Sample Input

6 5 3

1 2

1 5

3 4

5 2

1 3

1 4

2 3

5 6

样例输出 Sample Output

Yes

Yes

No

数据范围及提示 Data Size & Hint

n<=5000,m<=5000,p<=5000

思路thinkings

并查集模板题

10分钟,21行代码,一次AC(/自豪)

代码 codes

#include<iostream>
using namespace std;
int father[5005];
int n,m,p,a,b;
int find(int x){return x==father[x]?x:father[x]=find(father[x]);}
int main()
{
    cin>>n>>m>>p;
    for (int i=1;i<=n;i++) father[i]=i;
    for (int i=1;i<=m;i++)
    {
        cin>>a>>b;
        father[find(a)]=find(b);
    }
    for (int i=1;i<=p;i++)
    {
        cin>>a>>b;
        if ( find(a)==find(b) )  { cout<<"Yes"<<endl; } else { cout<<"No"<<endl;}
    }
    return 0;
}

结果 results

bubuko.com,布布扣

 

 

【水】wikioi1073 家族

标签:des   style   blog   http   color   io   os   strong   for   

原文地址:http://www.cnblogs.com/seekdreamer/p/3968277.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!